MIL MIL-C-83723/71B PDF

MIL MIL-C-83723/71B PDF

Name:
MIL MIL-C-83723/71B PDF

Published Date:
06/30/1992

Status:
Active

Description:

CONNECTORS, ELECTRICAL, (CIRCULAR, ENVIRONMENT RESISTING), RECEPTACLE, (FLANGE MOUNT, BAYONET COUPLING, CRIMP SOCKET CONTACT) SERIES III, CLASSES A, G, R, AND W (SUPERSEDING MIL-C-83723/71A)

Publisher:
Military Specifications and Standards

Document status:
Active

Format:
Electronic (PDF)

Delivery time:
10 minutes

Delivery time (for Czech version):
200 business days

SKU:
mil-mil-c-83723-71b_1434961

Choose Document Language:
7.20 €
Need Help?

File Size : 1 file , 130 KB
Note : This product is unavailable in Ukraine, Russia, Belarus
Number of Pages : 6
Published : 06/30/1992

History

MIL MIL-C-83723/71B
Published Date: 06/30/1992
CONNECTORS, ELECTRICAL, (CIRCULAR, ENVIRONMENT RESISTING), RECEPTACLE, (FLANGE MOUNT, BAYONET COUPLING, CRIMP SOCKET CONTACT) SERIES III, CLASSES A, G, R, AND W (SUPERSEDING MIL-C-83723/71A)
7.20 €
MIL MIL-C-83723/71A
Published Date: 11/13/1975
CONNECTORS, ELECTRICAL, (CIRCULAR, ENVIRONMENT RESISTING), RECEPTACLE, (FLANGE MOUNT, BAYONET, COUPLING, CRIMP SOCKET CONTACT), (SERIES III, CLASSES A, G AND R) (S/S BY MIL-C-83723/71B)
7.20 €

Related products

QPL QPL-28840-40
Published Date: 03/22/2006
CONNECTORS, ELECTRICAL, CIRCULAR THREADED, HIGH DENSITY, HIGH SHOCK SHIPBOARD, CLASS D, GENERAL SPECIFICATION FOR(SUPERSEDING QPL-28840-39)
7.20 €
MIL MIL-C-39029/108
Published Date: 04/30/1990
CONTACTS, ELECTRICAL CONNECTOR, PIN, CRIMP REMOVABLE, SOCKET, SINGLE WIRE (S/S BY SAE-AS39029/108)
7.20 €
MIL MIL-C-83723/76B
Published Date: 06/30/1992
CONNECTORS, ELECTRICAL, (CIRCULAR, ENVIRONMENT RESISTING), PLUG, (SINGLE HOSE MOUNT, BAYONET COUPLING, CRIMP PIN CONTACT), (SERIES III, CLASSES A, G, R, AND W) (SUPERSEDING MIL-C-83723/76A) (S/S BY MIL-DTL-83723/76C)
7.20 €
MIL MIL-DTL-83527/1C
Published Date: 01/13/2004
CONNECTOR, PLUG, ELECTRICAL, RECTANGULAR, MULTIPLE INSERT TYPE, RACK TO PANEL, ENVIRONEMENT RESISTING, 150 DEGREE CONTINUOUS OPERATING TEMPERATURE, SHELL SIZE 2 (SUPERSEDING MIL-C-83527/1B)
7.20 €

Best-Selling Products

IETF 8254-2
Published Date: 07/01/2016
Papiers et cartons - Mesurage du brillant spéculaire - Partie 2: Brillant à 75° avec un faisceau parallèle, méthode DIN
24.30 €
IETF FAA AC 43-10
Published Date: 02/01/1983
MECHANICAL WORK PERFORMED ON U.S. AND CANADIAN REGISTERED AIRCRAFT
IETF RFC 1000
Published Date: 08/01/1987
The Request for Comments Reference Guide
21.00 €
IETF RFC 1002
Published Date: 03/01/1987
PROTOCOL STANDARD FOR A NetBIOS SERVICE ON A TCP/UDP TRANSPORT: DETAILED SPECIFICATIONS
18.30 €
IETF RFC 1014
Published Date: 06/01/1987
XDR: EXTERNAL DATA REPRESENTATION STANDARD
IETF RFC 1042
Published Date: 02/01/1988
A Standard for the Transmission of IP Datagrams over IEEE 802 Networks
10.20 €